Page 5 of 11 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 107

Thread: Hauppauge HVR-2250 analog support issues with MythTV

  1. #41
    Join Date
    May 2005
    Beans
    33
    Distro
    Ubuntu 6.06

    Re: Hauppauge HVR-2250 analog support issues with MythTV

    So i have just installed 10.10 to give this a shot, and i am stuck on building the modules. Here is my output:

    Code:
    make -C /home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l 
    make[1]: Entering directory `/home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l'
    creating symbolic links...
    make -C firmware prep
    make[2]: Entering directory `/home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/firmware'
    make[2]: Leaving directory `/home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/firmware'
    make -C firmware
    make[2]: Entering directory `/home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/firmware'
    make[2]: Nothing to be done for `default'.
    make[2]: Leaving directory `/home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/firmware'
    Kernel build directory is /lib/modules/2.6.35-22-generic/build
    make -C /lib/modules/2.6.35-22-generic/build SUBDIRS=/home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l  modules
    make[2]: Entering directory `/usr/src/linux-headers-2.6.35-22-generic'
      CC [M]  /home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/au0828-video.o
    /home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/au0828-video.c: In function 'au0828_uninit_isoc':
    /home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/au0828-video.c:185: error: implicit declaration of function 'usb_buffer_free'
    /home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/au0828-video.c: In function 'au0828_init_isoc':
    /home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/au0828-video.c:255: error: implicit declaration of function 'usb_buffer_alloc'
    /home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/au0828-video.c:256: warning: assignment makes pointer from integer without a cast
    make[3]: *** [/home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l/au0828-video.o] Error 1
    make[2]: *** [_module_/home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l] Error 2
    make[2]: Leaving directory `/usr/src/linux-headers-2.6.35-22-generic'
    make[1]: *** [default] Error 2
    make[1]: Leaving directory `/home/angel12/Downloads/saa7164-v4l-8da3bd06a289/v4l'
    make: *** [all] Error 2

    Any ideas?

  2. #42
    Join Date
    Jun 2007
    Location
    Poughkeepsie, NY
    Beans
    5,814
    Distro
    Ubuntu

    Re: Hauppauge HVR-2250 analog support issues with MythTV

    Quote Originally Posted by angel12 View Post
    So i have just installed 10.10 to give this a shot, and i am stuck on building the modules. Here is my output...

    ...Any ideas?

    try it my way it will work

    Code:
    wget http://www.steventoth.net/linux/hvr22xx/firmwares/4019072/NXP7164-2010-03-10.1.fw
    sudo cp NXP7164-2010-03-10.1.fw /lib/firmware
    
    hg clone http://kernellabs.com/hg/~stoth/saa7164-v4l
    cd saa7164-v4l
    make CONFIG_DVB_FIREDTV:=n
    sudo make install
    sudo reboot
    Last night I lay in bed looking up at the stars in the sky and I thought to myself, where the heck is the ceiling.

  3. #43
    Join Date
    May 2005
    Beans
    33
    Distro
    Ubuntu 6.06

    Re: Hauppauge HVR-2250 analog support issues with MythTV

    Quote Originally Posted by LowSky View Post
    try it my way it will work

    Code:
    wget http://www.steventoth.net/linux/hvr22xx/firmwares/4019072/NXP7164-2010-03-10.1.fw
    sudo cp NXP7164-2010-03-10.1.fw /lib/firmware
    
    hg clone http://kernellabs.com/hg/~stoth/saa7164-v4l
    cd saa7164-v4l
    make CONFIG_DVB_FIREDTV:=n
    sudo make install
    sudo reboot
    same thing happens. it shouldnt matter that im on 64bit right?

    Edit: looks like its because i am on a 2.6.35 kernel: http://www.spinics.net/lists/linux-media/msg22089.html
    Last edited by angel12; October 21st, 2010 at 11:08 PM.

  4. #44
    Join Date
    Nov 2007
    Beans
    7

    Re: Hauppauge HVR-2250 analog support issues with MythTV

    This is a known problem with the 2.6.35 kernel... There will have to be a patch for the driver in order to work with this kernel... Report it to the developer Steven Toth... But you should be able to fix it pretty easily... the usb_buffer_free and usb_buffer_alloc methods were renamed...
    Last edited by dnobes; October 21st, 2010 at 11:12 PM.

  5. #45
    Join Date
    May 2005
    Beans
    33
    Distro
    Ubuntu 6.06

    Re: Hauppauge HVR-2250 analog support issues with MythTV

    Quote Originally Posted by dnobes View Post
    This is a known problem with the 2.6.35 kernel... There will have to be a patch for the driver in order to work with this kernel... Report it to the developer Steven Toth... But you should be able to fix it pretty easily... the usb_buffer_free and usb_buffer_alloc methods were renamed...
    Im somewhat a noob when it comes to this, what exactly should i have to do to fix it?

  6. #46
    Join Date
    Nov 2007
    Beans
    7

    Re: Hauppauge HVR-2250 analog support issues with MythTV

    Two ways to fix it...

    1)Find a header file that is inccluded in all the files that use either "usb_buffer_alloc" or "usb_buffer_free" and add:
    #define usb_alloc_coherent(a, b, c, d) usb_buffer_alloc(a, b, c, d)
    #define usb_free_coherent(a, b, c, d) usb_buffer_free(a, b, c, d)

    2)Go to each file that uses them and add it at the top of each one...
    Just look for them using "grep -r <looking for here> *" from the root directory.

  7. #47
    Join Date
    Jan 2007
    Beans
    29

    Thumbs down Re: Hauppauge HVR-2250 analog support issues with MythTV

    Hi all,

    Just wanted to report that I followed LowSky's guide from post #42 and I now have analogue working on both of the 2250's inputs! It's not perfect, the audio is very loud and I see a flash of blue when changing channels / inputs, but it is definitely better than nothing! One more note for anyone still having trouble, I had to delete all of my existing tuners from the backend and then add the 2250's tuner BEFORE adding my other card in order to get both of the 2250's tuners working. I'm going to look for ways to normalize the audio volume, but if anyone has any suggestions please chime in.

    Edit:

    Okay, I spoke a little to soon. Live tv works okay but recordings are messed up. A 1/2 hour recording shows up as 8 minutes or so in length. The entire program is there but the total time is very wrong, and trying to skip forward by 30 seconds results in actually skipping forward several minutes. My dmesg is full of this:

    Code:
    [87529.087639] No pack at 0x0
    [87529.087642] No pack at 0x800
    [87529.087644] No pack at 0x1000
    [87529.087647] No pack at 0x1800
    [87529.087649] No pack at 0x2000
    [87529.087652] No pack at 0x2800
    [87529.087655] No pack at 0x3000
    [87529.087657] No pack at 0x3800
    [87529.087660] No pack at 0x4000
    [87529.087662] No pack at 0x4800
    [87529.087665] No pack at 0x5000
    [87529.087667] No pack at 0x5800
    [87529.087670] No pack at 0x6000
    [87529.087672] No pack at 0x6800
    [87529.087675] No pack at 0x7000
    [87529.087677] No pack at 0x7800
    This repeats consistently as long as either 2250 tuner is active. If I pause a currently recording program and watch the total time, it increments by 1 second every 3 or 4 instead of every second.I have also posted my issue here:

    http://www.kernellabs.com/blog/?p=14...1#comment-1874

    I will post to this thread if I figure anything out.
    Last edited by jdk82; October 24th, 2010 at 08:42 PM. Reason: additional information

  8. #48
    Join Date
    Aug 2010
    Location
    Rcohester, NY USA
    Beans
    10

    Re: Hauppauge HVR-2250 analog support issues with MythTV

    I followed LowSky's instructions but it doesn't see the driver at the backend.
    Did a dmesg and got the following output.

    [ 9.908435] saa7164 driver loaded
    [ 9.908475] saa7164 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 9.909233] CORE saa7164[0]: subsystem: 0070:8891, board: Hauppauge WinTV-HVR2250 [card=7,autodetected]
    [ 9.909238] saa7164[0]/0: found at 0000:02:00.0, rev: 129, irq: 17, latency: 0, mmio: 0xfe400000
    [ 9.909243] saa7164 0000:02:00.0: setting latency timer to 64
    [ 10.076724] saa7164_downloadfirmware() no first image
    [ 10.076762] saa7164_downloadfirmware() Waiting for firmware upload (v4l-saa7164-1.0.3.fw)
    [ 10.103198] saa7164_downloadfirmware() Upload failed. (file not found?)

    Looks like the firmware didn't load right.

    How can I correct this?

    Radical Geek

  9. #49
    Join Date
    Jan 2007
    Beans
    29

    Re: Hauppauge HVR-2250 analog support issues with MythTV

    Hi RadicalGeek,

    It's looking for the wrong firmware, which would indicate that the driver did not build / install properly. Try following LowSky's instructions again and pay carefull attention to the output following the command

    Code:
    make CONFIG_DVB_FIREDTV:=n
    If it works properly you'll see a lot modules being built. It took about 10 minutes on my machine. It may be a good idea to capture the output of that command so you can post it here if it still doesn't work.

  10. #50
    Join Date
    Jun 2007
    Location
    Poughkeepsie, NY
    Beans
    5,814
    Distro
    Ubuntu

    Re: Hauppauge HVR-2250 analog support issues with MythTV

    saa7164-1.0.3.fw is for using the digital tuner, not analog, and even so it isn't install correctly.
    Last night I lay in bed looking up at the stars in the sky and I thought to myself, where the heck is the ceiling.

Page 5 of 11 FirstFirst ... 34567 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •